Another client_max_body_size query


#1

Hi

Apologies, tried my best to sift through the other posts, some in French, but coldn’t see a soulution.

I seem to be getting an error uploading images “File is too big (Max 10Mo)”. I’ve currently got the following settings in Nginx

nginx.conf (in http section) “client_max_body_size 1024M;”

cozy.conf (in server section) “client_max_body_size 1024M;”

Increasing these to 10240M and running “sudo service nginx reload”, doesn’t seem to solve the size error, is there anything else that limits the size?

Cheers


#2

Hello @noodlesuk,

Welcome aboard!

Setting client_max_body_size inside nginx.conf should be enough. Have you tried using a lowercase m and restarting the server instead of just reloading the configuration?


#3

Thanks for the welcome and thanks for Cozy, tried owncloud, Seafile on the quest for my own cloud storage on a RPi, Cozy is by far the quickest and has a nice interface.

Thanks, changing to ‘m’ seemed to work.