apt install cozy failing on dependancies


#1

running through the install instructions on deb 9.5
installing the through the testing branch

I make it all the way through to the finally step. when i type in

apt install cozy

apt comes back with a unmet dependencies error:

The following packages have unmet dependencies:
cozy : Depends: cozy-coclyco (>= 0.2.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When I apt install cozy-coclyco i get a python3-acme and a python3-joespy dependancy problem, i can install python3-acme but not joespy it doenst like the expected version.

any thoughts what I might have missed to not have these seemingly required dependencies?


#2

Hi @caddy
You must activate backports repositories, because we need a more recent version of josepy than the one available on stable repositories.


#3

yes, I thought I had gone in and done that but seems i did not save the change or something when I edit the apt repository.

everything is working now.