Bankin' Impossible de se connecter avec les identifiants

Bonjour la communauté,

Voici mon problème :

Comportement attendu

Je souhaite me connecter avec mon login et pwd sur la plateforme bankin’ via le connecteur.

Comportement constaté

J’ai ce message d’erreur :
> Erreur de Connexion
> Une erreur inconnue est survenue

Logs

May 25 12:06:35 labo cozy[28339]: time="2021-05-25T12:06:35Z" level=error msg="{\"error\":\"code=403, message=Forbidden\"}" domain=***.***.com job_id=6277d48d603018994a9e82d3287fa27e nspace=jobs slug=bankin worker_id=konnector/5

May 25 12:06:35 labo cozy[28339]: time="2021-05-25T12:06:35Z" level=error msg="Stderr: (node:1) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.\n(Use `nodejs --trace-deprecation ...` to show where the warning was created)\n" domain=***.***.com  job_id=6277d48d603018994a9e82d3287fa27e nspace=jobs slug=bankin worker_id=konnector/5

Avez-vous une idée ?

Salut,

Cette fois-ci on a donc une erreur différente de la dernière fois. :smiley:
Malheureusement je n’ai pas suffisamment d’information donc je ne sais pas à quel moment tu t’es fais jeté. :thinking: Il va falloir que je détaille un peu plus les logs pour qu’on puisse investiguer ça ensemble.

PS: merci @Clochix pour le ping

Hello @Clochix et @Naji,

Voilà plus en détail. Pour info, c’est au moment ou je fais pour la première fois la connexion :

May 25 19:44:16 *** cozy[28339]: time="2021-05-25T19:44:16Z" level=info msg="trigger @event(6277d48d603018994a9e82d328257bea): Pushing new job service" domain=***.***.com nspace=mem-scheduler

May 25 19:44:17 *** cozy[28339]: time="2021-05-25T19:44:17Z" level=error msg="Unexpected token u in JSON at position 0" domain=***.***.com job_id=6277d48d603018994a9e82d328802f4a name=updateAccounts nspace=jobs slug=home worker_id=service/5

May 25 19:44:17 *** cozy[28339]: time="2021-05-25T19:44:17Z" level=info msg="Service success" domain=***.***.com exec_time=435.048334ms job_id=6277d48d603018994a9e82d328802f4a name=updateAccounts nspace=jobs slug=home worker_id=service/5

May 25 19:44:19 *** cozy[28339]: time="2021-05-25T19:44:19Z" level=error msg="format is not a function" domain=***.***.com job_id=6277d48d603018994a9e82d3288031d9 nspace=jobs slug=bankin worker_id=konnector/7

May 25 19:44:20 *** cozy[28339]: time="2021-05-25T19:44:20Z" level=error msg="{\"error\":\"code=403, message=Forbidden\"}" domain=***.***.com job_id=6277d48d603018994a9e82d3288031d9 nspace=jobs slug=bankin worker_id=konnector/7

May 25 19:44:20 *** cozy[28339]: time="2021-05-25T19:44:20Z" level=error msg="Stderr: (node:1) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.\n(Use `nodejs --trace-deprecation ...` to show where the warning was created)\n" domain=***.***.com job_id=6277d48d603018994a9e82d3288031d9 nspace=jobs slug=bankin worker_id=konnector/7

May 25 19:44:20 *** cozy[28339]: time="2021-05-25T19:44:20Z" level=warning msg="Error while performing job: {\"error\":\"code=403, message=Forbidden\"} (retry in 57.573205ms)" domain=***.***.com job_id=6277d48d603018994a9e82d3288031d9 nspace=jobs worker_id=konnector/7

May 25 19:44:22 *** cozy[28339]: time="2021-05-25T19:44:22Z" level=error msg="format is not a function" domain=***.***.com job_id=6277d48d603018994a9e82d3288031d9 nspace=jobs slug=bankin worker_id=konnector/7

May 25 19:44:22 *** cozy[28339]: time="2021-05-25T19:44:22Z" level=error msg="{\"error\":\"code=403, message=Forbidden\"}" domain=***.***.com job_id=6277d48d603018994a9e82d3288031d9 nspace=jobs slug=bankin worker_id=konnector/7

May 25 19:44:22 *** cozy[28339]: time="2021-05-25T19:44:22Z" level=error msg="Stderr: (node:1) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.\n(Use `nodejs --trace-deprecation ...` to show where the warning was created)\n" domain=***.***.com job_id=6277d48d603018994a9e82d3288031d9 nspace=jobs slug=bankin worker_id=konnector/7

May 25 19:44:22 *** cozy[28339]: time="2021-05-25T19:44:22Z" level=info msg="Konnector failure: {\"error\":\"code=403, message=Forbidden\"}" account_id=6277d48d603018994a9e82d32870d43d domain=***.***.com exec_time=4.486129555s job_id=6277d48d603018994a9e82d3288031d9 nspace=jobs slug=bankin version=1.1.0 worker_id=konnector/7

May 25 19:44:22 *** cozy[28339]: time="2021-05-25T19:44:22Z" level=error msg="error while performing job: {\"error\":\"code=403, message=Forbidden\"}" domain=***.***.com job_id=6277d48d603018994a9e82d3288031d9 nspace=jobs worker_id=konnector/7

Ah ça c’est une erreur que je connais, je l’ai déjà corrigé. Du coup es-tu sûre que tu as la dernière version du konnector? Pourrais-tu vérifier et me dire quelle version tu as installé ? La dernière version étant la 1.2.2-ee1046d2aa10a90b65384af4b3a982ef67f3d111.

Comment faire pour savoir la version ?

cozy-stack konnectors ls --domain ***.***.com

Merci !! Voici ce que me renvoie la commande :slight_smile:

bankin      registry://bankin/stable      1.1.0   ready

Effectivement je ne suis pas en 1.2.2.
Comment mettre à jour le konnector ?
Au hasard (en reprenant ta commande d’avant) :

cozy-stack konnectors upgrade bankin --domain ***.***.com

Presque :wink:

cozy-stack konnectors update bankin --domain ***.***.com

La commande cozy-stack a une aide en ligne plutôt bien foutue, il suffit de taper cozy-stack pour voir les commandes disponibles, puis cozy-stack commande pour avoir les options.

Par contre, les connecteurs devraient se mettre à jour automatiquement.
Si j’en crois Le Registre, la version 1.2.2 n’a pas encore été officiellement publiée.

@Naji est-ce que tu as besoin qu’on publie une nouvelle version ?

Ah oui en effet, j’avais oublié ce détails ! Perso je l’ai installé depuis le répo git directement pour pouvoir tester plus rapidement. Donc si c’est possible oui cela m’arrangerait stp :slight_smile:

Je tente une invocation de @lucas :wink:

Trop fort les gars ;-). J’attends donc que la new version soit sur le repo officiel. Bipez moi quand c’est good :sunglasses:

J’ai quand même testé la ligne et ca me renvoie :

cozy-stack konnectors update bankin --domain ***.***.com
bankin is already up-to-date at 1.1.0

Hello les gars,

@Clochix, @Naji, @lucas

Je viens aux nouvelles :wink:

curl -s https://apps-registry.cozycloud.cc/selfhosted/registry/bankin | jq -r '.latest_version.version' → 1.1.0.

Hélas, mon invocation n’a pas fonctionné :crying_cat_face:

/me retourne à l’école consulter des grimoires.

Ahh zut !! @Clochix, Je crois savoir qu’on peut le faire manuellement depuis github la MAJ. Si jamais, peux-tu me mettre les consignes pour le faire manuellement ?

(pas la peine de me mentionner explicitement, je reçois des notifications pour tout ce qui se passe sur le forum).

Tu peux peut-être essayer cozy-stack konnectors update bankin registry://bankin/dev/1.2.1-dev.41d2eaf1617262429311 --domain ***.***.com mais je ne sais pas si ça va fonctionner, ça fait longtemps que je n’ai plus joué avec les connecteurs.

J’ai essayé de relancer mes camarades pour qu’ils publient la dernière version, il n’y a malheureusement pas grand chose d’autre à faire qu’attendre qu’ils trouvent le temps de le faire.

Je ne savais pas si tu étais notifié de tout ou juste quand on te nomme. Parce que j’ai vu que c’est une option dans le settings. Du coup vu que tu me répondais plus vite quand j’utilisais l’arobase, j’en ai déduit que… :laughing: :sweat_smile: bref autant pour moi :wink:

J’ai lancé la commande… C’est bien upgrade !!! youhouuu
bankin registry://bankin/dev/1.2.1-dev.41d2eaf1617262429311 1.2.1-dev.41d2eaf1617262429311 ready

J’ai ensuite supprimé le compte ou j’essayais de me connecter, puis j’ai relancé l’app et je me suis connecté à nouveau.

Congratulation :sunglasses: :sunglasses: :sunglasses: :laughing:

Bravo et merci

PS j’espère que tes camarades le publiera rapidement :innocent: :blush:

1 Like

Sensass !

Tu es débloqué, c’est déjà ça. Une fois le connecteur officiellement publié, je te préviendrai de repasser sur la version stable. Je ne sais plus trop quelles sont les règles de mise à jour des connecteurs, il est possible que tu te retrouves à présent « branché » sur les versions de développement du connecteur, donc te retrouves parfois avec des versions pas forcément stables.

Pour ce qui est du délai de réponse, ça dépend de mon statut. Tu auras noté que je suis un chat, donc fais la sieste environ 23h par jour, je ne répond que durant les brefs intervalles entre deux siestes.

3 Likes

Merci pour ces infos, j’attendais depuis pas mal de temps que le problème soit corrigé (~1 an et demi si ma mémoire est bonne).

Je repasserais aussi en version stable lorsque celle-ci sera publié.

1 Like