COZY Pass - Autohébergement, erreur lors de la mise à jour de l'indice

Bonjour à tous,

Je souhaite tester cozy pass sur mon infra auto hébergée, cependant je n’arrive pas à passer l’étape 3 : définir un indice.

Dans les logs de la stack j’ai ça :

Sep 21 12:22:20 cozyServer cozy[760]: time=“2020-09-21T12:22:20+02:00” level=error msg=“GET /settings/hint code=404, message=Not Found” domain=mondomaine nspace=http
Sep 21 12:22:21 cozyServer cozy[760]: time=“2020-09-21T12:22:21+02:00” level=error msg=“GET /settings/hint code=404, message=Not Found” domain=mondomaine nspace=http
Sep 21 12:22:23 cozyServer cozy[760]: time=“2020-09-21T12:22:23+02:00” level=error msg=“PUT /settings/hint code=404, message=Not Found” domain=mondomaine nspace=http
Sep 21 12:22:38 cozyServer cozy[760]: time=“2020-09-21T12:22:38+02:00” level=error msg=“PUT /settings/hint code=404, message=Not Found” domain=mondomaine nspace=http

Je n’ai pas défini le serveur smtp pour l’envoi des mails, peut être est ce dû à cela ?

Merci pour votre aide.
Clément

Hello @cpique,

Les 404 sur les GET sont normales, puisqu’il n’existe pas encore d’indice. Par contre je ne comprend pas pourquoi la définition de l’indice ne fonctionne pas.
Est-ce que ton serveur est à jour ?

Non, c’est sans rapport.

Merci pour ta réponse.

cozy-stack version me renvoie :

2:1.4.0

aucune maj disponible dans ma debian

Tu as un souci de mise à jour car la dernière version que nous avons publié est la 1.4.17 :
https://apt.cozy.io/debian/pool/testing/c/cozy-stack/

Effectivement, en 1.4.0, les routes pour gérer l’indice n’existaient pas encore.

Bizarre, j’ai pourtant bien ça dans mon sources.list

deb https://apt.cozy.io/debian/ stretch testing

Voici ce que je trouve dans apt.cozy.io/debian/dists/stretch/testing/binary-amd64/ :

Package: cozy
Priority: extra
Section: devel
Installed-Size: 9
Maintainer: aeris aeris@cozycloud.cc
Architecture: all
Source: cozy-stack
Version: 2:1.4.0-1

Euh, Stretch, c’est l’ancienne stable, qui a été remplacée par Buster en décembre 2019.
Et nos derniers paquets nécessitent d’être en Buster. Je crains qu’il ne te faille mettre à jour ta Debian.

1 Like

Ok, j’avoue ne pas avoir suivi que cozy avait besoin de passer sur buster…

Je fais donc ça, merci :wink:

EDIT: cela a bien fonctionné

1 Like