Cozy setup trouble

Hi, I am right at this stage
And more precisely when you modify cozy.yaml.local.
Mine has 2 entries:
host : x.x.x.x
port : 8080
and
admin :
host : y.y.y.y
port : 6060

which one should I modify ?

http://localhost:5984/ does respond correctly : {“couchdb”:“Welcome”,“version”:“2.3.1”,“git_sha”:"",“uuid”:""",“features”:[“pluggable-storage-engines”,“scheduler”],“vendor”:{“name”:“The Apache Software Foundation”}}

but http://IPVM:5984/ does not :
curl: (7) Failed to connect to IPVM port 5984: Connexion refusée

Precision : localhost is VM

the first one obviously as port is 8080 …

Hi,

Please don’t fork an existing & old thread to ask for something completely unrelated to the initial thread subject.

You don’t provide enough context about what you try to do.
cozy.yaml.local is not supposed to be edited on our official documentation and for a standard setup, you have nothing to modify.

but http://IPVM:5984/ does not :
curl: (7) Failed to connect to IPVM port 5984: Connexion refusée

This is totally normal, CouchDB is only supposed to be accessed locally and must not be exposed on a non local & private IP address.

1 Like

désolé pour le bazar … j’ai écris au fur et à mesure de mon avancements en me disant que d’autres traverseraient peut-être les mêmes affres …
j’ai essayé de comprendre …
Je suis derrière un synology, le montage est donc le suivant :
syno : adresse ip y.y.y.y
VM debian hébergée sur le syno : adresse ip : x.x.x.x
Cozy-stack + cozy + couchdb installés sur la VM et fonctionnels (vérif curl …)
le fichier /etc/cozy/cozy.yml.local a été modifié pour pointer vers x.x.x.x (vers y.y.y.y le status est failed à la relance du service)
Certificats Letsencrypt installés sur le syno
Les DNS sont renseignés chez mon provider
le reverse proxy est renseignés sur son syno mais question : *.cozy.ndd.fr -> x.x.x.x:8080 ou bien y.y.y.y:8080 ? parce que pour le moment home.cozy.ndd.fr pointe vers ça si le reverse est x.x.x.x:


et vers ça, si le reverse pointe vers y.y.y.y

Je pense ne pas être loin mais je sèche …

La seule chose à changer est l’adresse du :8080, la mettre à 0.0.0.0 ou :: pour faire écouter autre part que sur localhost. Ne surtout pas exposer le 6060 ailleurs que sur localhost (interface d’admin).

y.y.y.y, c’est bien le syno qui est accédé par les utilisateurs (le port n’est jamais définit dans un champ A/AAAA).
Et le syno qui doit faire la redirection derrière, modulo de la config chez lui (lire le manuel du NAS pour savoir comment ajouter des vhosts et s’en servir comme reverse-proxy) pour lui faire comprendre que tout *.cozy.ndd.fr doit être envoyé vers x.x.x.x.

Merci Aeris pour ton aide … les modifications ont été faites selon tes conseils sauf pour le vhost, je dois d’abord comprendre ce que c’est et comment ça fonctionne … si des pro de syno sont ds le coin et peuvent m’aider, je suis à l’écoute !

Bonjour,

Je suis dans la mĂŞme configuration que toi et voici ma conf syno

La création d’un certificat pour cozy; drive; home; settings; store…

ensuite il te faut une entrée par domaine à savoir dans le portail des applications pour moi 5

source: cozy.tondomaine.com
port 443
cocher hsts et http/2

Destination:
http
ip de ta VM ou nom interne si tu as un DNS

port 8080

Entête personnalisée
host:$host

Voila j’ai cette configuration sur chaque nom de domaine et impeccable tout fonctionne depuis des mois sans soucis :smiley:

En espérant que cela pourra t’aider j’avoue que quand je l’ai mis en place j’ai galéré heureusement qu’Aeris était là

1 Like

Merci Alex81 pour ton aide (et Aeris aussi !).
je bute encore sur les accès. Le portail des applications est correctement renseigné mais je persiste :

ERR_NAME_NOT_RESOLVED
.
Je ne suis plus très loin mais je bloque
j’ai revérifié les enregistrements dns (image ) )maintenant j’ai ça:

404 Client Error: Not Found for url: http://cozy.ndd.fr/.well-known/acme-challenge/#dskjfhklsfhSDVKsjdkhgdsgkjgjkg au lancement de
cozy-coclyco create cozy.ndd.fr cedric@ndd.fr

je n’arrive pas à franchir le NAS et renvoyer la requête sur la MV … je bute sur la page d’accueil nginx du NAS …

Je chercherai demain, j’ai le document d’installation rédigé lors de mon installation. Je vais voir pour te le mettre à dispo

merci parce que là je tourne en rond …

Aller je me lance

Voici les étapes réalisées sur mon serveur Debian hébergé par un synology afin d’installer la suite cozy.

Suivre les étapes décrites dans la doc officielle: Ici

Installer Nedejs
Configurer les Repo Cosy
Installer CouchDB en standalone sur 127.0.0.1
Installer cosy-stack
Ne pas lancer la partie apt install cozy. Elle est pas nécessaire dans le cadre d’un hébergement derrière le NAS. C’est lui que va tout faire.

A ce stade cozy est en Ă©coute sur 127.0.0.1 et que lĂ  dessus.
On modifie le fichier /etc/cozy/cozy.yml.local afin de lui donner l’ip du serveur

host: “Ip du serveur”
port: 8080

admin:
  host: 127.0.0.1
  port: 6060

couchdb:
  url: http://cozy:XXX@127.0.0.1:5984/

jobs:
  workers:
    konnector:
      max_exec_count: 3
      timeout: 600s

Relancer le service

systemctl restart cozy-stack.service

lsof -i -P
COMMAND     PID       USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
cozy-stac 10684 cozy-stack    7u  IPv4  46864      0t0  TCP localhost:39267 (LISTEN)
cozy-stac 10684 cozy-stack    8u  IPv4  46874      0t0  TCP localhost:6060 (LISTEN)
cozy-stac 10684 cozy-stack    9u  IPv4  46876      0t0  TCP “Ip du serveur”:8080 (LISTEN)

Création de l’instance:

cozy-stack instances add --passphrase xxxxxxxxxxxxxx --apps drive,settings,home,store --locale fr "le domaine déclaré dans ton dns"

Personnellement, dans mon dns ovh j’ai du créer un cname pour l’url générale et chaque sous domaine drive,settings,home,store

Quand l’installation est fini:

systemctl status cozy-stack

â—Ź cozy-stack.service - Cozy service
   Loaded: loaded (/lib/systemd/system/cozy-stack.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2020-06-13 09:19:31 CEST; 19min ago
 Main PID: 10684 (cozy-stack)
    Tasks: 8 (limit: 2359)
   Memory: 139.6M
   CGroup: /system.slice/cozy-stack.service
           └─10684 /usr/bin/cozy-stack serve

juin 13 09:19:32 debian-server cozy-stack[10684]:   http server admin started on "127.0.0.1:6060"
juin 13 09:19:32 debian-server cozy-stack[10684]:   http server major started on "192.168.0.5:8080"
juin 13 09:38:18 debian-server cozy[10684]: time="2020-06-13T09:38:18+02:00" level=info msg=Start domain=cosy.backup.familleblav.ovh nspace=apps slug=drive type=install version_start=
juin 13 09:38:24 debian-server cozy[10684]: time="2020-06-13T09:38:24+02:00" level=info msg="Successful installer process: 1.25.0" domain=cosy.backup.familleblav.ovh nspace=apps slug=drive type=install version_start=
juin 13 09:38:24 debian-server cozy[10684]: time="2020-06-13T09:38:24+02:00" level=info msg=Start domain=cosy.backup.familleblav.ovh nspace=apps slug=settings type=install version_start=
juin 13 09:38:26 debian-server cozy[10684]: time="2020-06-13T09:38:26+02:00" level=info msg="Successful installer process: 1.14.0" domain=cosy.backup.familleblav.ovh nspace=apps slug=settings type=install version_start=
juin 13 09:38:26 debian-server cozy[10684]: time="2020-06-13T09:38:26+02:00" level=info msg=Start domain=cosy.backup.familleblav.ovh nspace=apps slug=home type=install version_start=
juin 13 09:38:29 debian-server cozy[10684]: time="2020-06-13T09:38:29+02:00" level=info msg="Successful installer process: 1.30.2" domain=cosy.backup.familleblav.ovh nspace=apps slug=home type=install version_start=
juin 13 09:38:29 debian-server cozy[10684]: time="2020-06-13T09:38:29+02:00" level=info msg=Start domain=cosy.backup.familleblav.ovh nspace=apps slug=store type=install version_start=
juin 13 09:38:30 debian-server cozy[10684]: time="2020-06-13T09:38:30+02:00" level=info msg="Successful installer process: 1.9.2" domain=cosy.backup.familleblav.ovh nspace=apps slug=store type=install version_start=

On y voit bien chaque domaine

Partie Synology
J’ai créé un certificat spécifique pour les url de cozy
Ce certificat porte cozy.mondomaine ainsi que drive.mondomaine, settings.mondomaine, home.mondomaine, store.mondomaine

Les Vhosts cosy sont configurés comme suit:
Onglet général:

Source:

protocole:https
Nom d’hôte: (il faudra créer un Vhost par domaine)
Port: 443

Activer: HSTS
Activer HTTP/2

Destination:

Protocole: HTTP
Nom d’hôte: IP de la VM
port: 8080

Onglet En-tête personnalisé
Créer le nom d’entête Host ayant pour valeur $host

Il faut construire un Vhost par domaine soit un pour cosy, un pour drive,…

Il faut ensuite affecter le certificat créé précédemment sur chaque Vhost.

Si tout c’est bien passé l’accés à https://domaine doit fonctionner.

avant tout chose vérifie que ta VM résoud tes entrées DNS. Sans cela ça marche pas.

Essaie sur ta VM un Nslookup des différents noms. Je pense pas que ton problème vienne du nas

Un Grand merci pour ton tuto. Ton dernier message m’interpelle, Je pense que là est le problème … nslookup sur cozy.ndd.fr renvoie bien IP box mais pas les setttings.cozy.nnd.fr

Effectivement avant de lancer la commande de création de ta stack cozy, il faut absolument que la résolution DNS fonctionne pour chaque enregistrement.

Je te conseille de créer des CNAME sur ton nom de domaine principal et de tester les résolutions.

Il m’est arrivé de devoir recréer un enregistrement chez mon fournisseur car il ne s’était pas diffusé.

Tiens moi au courant

si je checke la résolution DNS sur un site https://www.whatsmydns.net/#CNAME/home.cozy.ndd.fr
j’ai ceci comme résultat :
image
mais si j’essaie de joindre cette même adresse depuis un navigateur : ERR_NAME_NOT_RESOLVED
et nslookup home.cozy.ndd.fr donne :
Server: 192.168.0.254
Address: 192.168.0.254#53

** server can’t find home.cozy.ndd.fr: NXDOMAIN

Non avant de voir ce qui ce passe sur le wan, tu dois te connecter à la machine qui hébergera ton cozy.

tu testes que ta machine résoud chaque nom.
exemple

host cozy.mondomaine
cosy.backup.familleblav.ovh has address xxx.xxx.xxx.xxx

host home.cozy.mondomaine
home.cozy.mondomaine is an alias for cozy.mondomaine
cozy.mondomaine has address xxx.xxx.xxx.xxx

Evidement l’IP doit toujours être la même.

Quand le souci de résolution est traité, tu pourras installer ta stack correctement et ça fonctionnera

Pour rappel aussi, cozy-coclyco n’est pas utilisable dans ce mode, parce qu’il va chercher à générer des certificats qu’il ne peut pas émettre.

oui je confirme c’est pour cela que j’en parle pas dans ma pseudo doc. Mais c’est mieux en le précisant.

Je ne peux que confirmer les derniers posts.
La resolution des dns est primordiale. Chez GANDI, il faut renseigner A par sous-domaine et non CNAME, ce qui m’a valu de m’arracher les (qques) cheveux qu’il me reste.
La partie cozy-coclyco, je m’en suis vite aperçu, est redondante avec un auto-hébergement+letsencrypt sur serveur dédié.
Merci pour vos aides respectives, grâce à vous j’ai bcp appris (et encore maintenant).