Drive et Photos ne s'affiche pas


#1

Bonjour,
J’ai installé cozy en suivant la doc, en auto-hébergement, sur une Debian Stretch, et quand je navigue sur drive ou photos rien ne s’affiche à part le titre de l’onglet et le favicon. Les autres apps fonctionnent (home, settings, contacts , store…). j’ai tenté un purge cozy puis re-install (pareil avec l’instance [je l’ai détruite puis recréée]) mais rien à faire, j’ai aussi testé l’affichage avec FF et chrome mais aucune différence… Quelqu’un a une idée ? Cordialement


#2

Hello @n0body,

Bienvenue à bord :smile:

La première chose à faire pour essayer de comprendre ce qui se passe est d’ouvrir les outils de développement Web et de regarder ce qui se passe lorsque tu accèdes aux applications Drive et Photos : est-ce que tu vois des erreurs dans la console du navigateur ? Est-ce que dans l’onglet réseau, certaines requêtes retournent des erreurs ?


#3

Hello Clochix ! Merci.
Oui j’ai :
ReferenceError: cozy is not defined
dans la console, mais ça ne me parle pas trop et je n’y connais rien en debuggage web,
je pencherais pour une erreur dans la création de l’instance mais je ne sais pas…
Tu as une idée ?


#4

Ah oui excuse moi j’avais zappé ta seconde question : dans réseau tout à l’air OK : HTTP code 200, que du vert.


#5

Non, je n’ai malheureusement pas d’idée, je vais essayer de trouver quelqu’un de l’équipe technique.


#6

Salut @n0body,

  • Est-ce que tu peux me dire quelle version ça essaye de t’installer ? (avec un cozy-stack apps ls --domain foo.bar)
  • Logiquement, ce “cozy” est servi par la stack à l’application. Est-ce que tu vois passer dans ton onglet network une requête vers “assets/js/cozy-client.*.min.js” ?

#7

Salut _Crash,

Alors pour :

cozy-stack apps ls --domain foo.bar

J’ai :

collect registry://collect/stable 2.4.4 ready
contacts registry://contacts/stable 0.8.5 ready
drive registry://drive/stable 1.18.7 ready
home registry://home/stable 1.18.0 ready
photos registry://photos/stable 1.18.7 ready
settings registry://settings/stable 1.11.0 ready
store registry://store/stable 1.7.1 ready

et oui je vois bien passer une requête dans l’onglet réseau vers “assets/js/cozy-client.*.min.js"


#8

UP !?

Il n’y aurait pas une doc pour installer la V3 en auto-hébergé ? sur une buster par exemple !? ^^
J’ai l’impression que la doc que j’ai utilisé (et qui se trouve ici : https://docs.cozy.io/en/tutorials/selfhost-debian/ ) date un peu, non ?


#9

Bonsoir @n0body,

Cette documentation est la plus récente et la seule que nous ayons pour Cozy.
Elle date de Stretch. Nous n’avons pas eu le temps de la mettre à jour depuis la sortie de Buster, et je ne sais pas si l’installation fonctionne encore avec cette version. Malheureusement, toute l’équipe est très occupée, et nous manquons de temps pour mettre à jour la documentation.


#10

Salut Clochix, _Crash !
Alors j’ai un cozy drive qui fonctionne sur une VM buster (image openstack qcow2 [réinitialisation du password root en démarrant sur init] j’avais la flemme de me taper l’install ! ^^) voilà la procédure :

apt install nginx ssl-cert msmtp git build-essential curl
adduser www-data ssl-cert
cd /usr/src/

installation ImageMagick

wget https://imagemagick.org/download/ImageMagick-7.0.8-61.tar.bz2
tar xvjf ImageMagick-7.0.8-61.tar.bz2
cd ImageMagick-7.0.8-61
./configure --with-modules --enable-shared --with-perl
make
make install
ldconfig /usr/local/lib
cd …

installation dependances pour couchdb

curl -sL https://deb.nodesource.com/setup_12.x | bash -
curl -sL https://dl.yarnpkg.com/debian/pubkey.gpg | apt-key add -
echo “deb https://dl.yarnpkg.com/debian/ stable main” | tee /etc/apt/sources.list.d/yarn.list
apt update && apt install -y nodejs yarn

apt --no-install-recommends -y install pkg-config erlang erlang-reltool libicu-dev libcurl4-openssl-dev python-pip python-sphinx
pip install --upgrade sphinx_rtd_theme nose requests hypothesis

installation js

apt install devscripts libffi-dev libnspr4-dev pkg-kde-tools autoconf
git clone https://github.com/apache/couchdb-pkg.git
cd couchdb-pkg
make couch-js-debs PLATFORM=$(lsb_release -cs)
dpkg -i js/*.deb
cd …

installation couchdb

git clone https://github.com/apache/couchdb.git
cd couchdb
./configure
make release
adduser --system --shell /bin/bash --group --gecos “CouchDB Administrator” couchdb
passwd couchdb
cp -R rel/couchdb /home/couchdb
chown -R couchdb.couchdb /home/couchdb
find /home/couchdb -type d -exec chmod 0770 {} ;
chmod 0644 /home/couchdb/couchdb/etc/
cp /usr/src/couchdb-pkg/debian/couchdb.service /lib/systemd/system/
vim /lib/systemd/system/couchdb.service
on change :
ExecStart=/opt/couchdb/bin/couchdb
par :
ExecStart=/home/couchdb/couchdb/bin/couchdb
(:wq)
systemctl daemon-reload
systemctl start couchdb.service

on recupere la derniere version de l’executable de la cozy-stack

cd /usr/src
mkdir -p bin/cozy-stack
cd bin/cozy-stack
wget https://github.com/cozy/cozy-stack/releases/download/1.3.1/cozy-stack-linux-amd64
chmod +x cozy-stack-linux-amd64
adduser cozy
chgrp cozy cozy-stack-linux-amd64

login cozy
cd /usr/src/bin/cozy-stack
mkdir ~/.cozy && ./cozy-stack-linux-amd64 config passwd ~/.cozy/cozy-admin-passphrase
vim ~/.cozy.yml
on met :
couchdb:
url: http://<couch_user>:<couch_password>@localhost:5984/
(:wq)

login root
curl -s -X PUT http://localhost:5984/_node/couchdb@127.0.0.1/_config/admins/admin -d ‘“mon_passwd”’
curl -s -X PUT http://localhost:5984/_node/couchdb@127.0.0.1/_config/admins/cozy -d ‘“mon_passwd”’ --user admin

systemctl stop couchdb.service
systemctl start couchdb.service

mkdir /usr/src/bin/cozy-stack/storage
chown cozy.cozy /usr/src/bin/cozy-stack/storage

login cozy
./cozy-stack-linux-amd64 -c ~/.cozy/cozy.yml serve

login cozy
./cozy-stack-linux-amd64 instances add --apps home,drive,settings,store --passphrase cozy mondomain

Je ne mets pas la conf nginx (proxy-pass 127.0.0.0:8080) ni lets encrypt il y a plein de doc la-dessus…

Voilà, c’est un peu long mais ça aidera peut-être quelqu’un en attendant que vous fassiez une doc avec un process un peu plus automatisé.

A+


#11

Merci beaucoup @n0body, je transmet à notre spécialiste es auto-hébergement, @aeris