Erreur suite à la mise à jour

backlog
bug

#1

Bonjour,
très heureux d’apprendre que la synchro ubuntu va être possible !

j’ai procédé à l’install.
L’appli s’est lancée et s’est mise à jour (CozyDrive-3.4.1-beta.1-x86_64 maintenant)

j’ai ensuite relancé et j’ai eu cette erreur :

Error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21’ not found (required by /tmp/.org.chromium.Chromium.5sVoJN): unable to import leveldown

tu aurais une solution ?

autre (petit) pb : j’avais fait un lancer sur l’appli mais le nom change à chaque mise à jour.
l’utilisation d’un lanceur n’est pas possible ?

merci pour ton aide,
X.


L’application GNU/Linux est gourmande en ressources
Créer des paquets pour installer Cozy Drive pour ordinateur sur Debian GNU/Linux et Ubuntu
#2

Hello @Xavier,

Merci de ce signalement, je crée un sujet spécifique pour le traiter plus efficacement.

Nous allons regarder.

Je vais me renseigner.


#3

ok, sur l’install, j’ai un peu progressé.
je suis sous ubuntu 14.04 et GLIBCXX n’allait que jusqu’à la version GLIBCXX_3.4.19
dans les forum j’ai trouvé un ppa qui permet d’avoir plus: ppa:ubuntu-toolchain-r/test
maintenant, j’ai la version GLIBCXX_3.4.21 et même jusque 24.

Mais un autre pb est apparu et là je cale un peu.

voici le message au lancement en ligne de commande de cozyDrive :

installed: X-AppImage-BuildId=2a5c83e0-ea32-11a7-067d-4f2d5ae49976 image: X-AppImage-BuildId=2a5c83e0-ea32-11a7-067d-4f2d5ae49976
/tmp/.mount_CozyDrGFMAJb/app/cozydrive: relocation error: /tmp/.org.chromium.Chromium.kvmzxb: symbol _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE9_M_createERmm, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference

tu as une idée ?


#4

Si tu as un conflit de glibc, c’est assez (voire très) intrusif de chercher à l’upgrader, tu risques plus de casser le reste de ton système qu’autre chose.
Il faut qu’on regarde de notre côté pour livrer des appimage pour chaque glibc qu’on souhaite surporter je pense.


#5

ok, je fais marche arrière de mon côté.
et j’attends votre retour.

merci pour tout.


#6

@Xavier les dev de l’appli sont en train d’analyser ton problème, mais comme nous avons eu des remontés de plusieurs plantages différents de l’application ce ouikende, ça prend un peu de temps.

/cc @sebn


#7

pas de soucis.
Entre-temps je suis passé en xubuntu 16.04 : ça fonctionne, j’ai pu me synchroniser.

par contre, j’ai le même pb que pour la V1 : la phase de préparation à la synchronisation dure très longtemps (j’ai plusieurs milliers de fichiers) mais surtout elle est très consommatrice de ressource cpu (la plupart du temps presque 100%, pendant 1 ou plusieurs heures).
Ce qui fait que je dois lancer le processus à part pour ne pas être dérangé.
Je ne peux pas lancer cozy-drive à chaque démarrage.

Est-ce normal ?


L’application GNU/Linux est gourmande en ressources
#8

6 messages ont été intégrés dans un sujet existant : L’application GNU/Linux est gourmande en ressources


#9

J’ai créé un sujet spécifique pour tes soucis de consommation de ressources, afin d’assurer un meilleur suivi.


#10

Hello, merci beaucoup pour tous les tests et les retours @Xavier !

Concernant le problème de version de glibc, on va essayer de recenser progressivement les versions des distributions supportées dans la documentation de l’application Cozy Drive (je vais rajouter la tienne). Si on essaie de se baser sur une glibc plus ancienne pour les builds, il y a un risque que ça ne fonctionne plus sur les distributions plus récentes. Une solution serait de modifier la façon dont sont générés les fichiers AppImage pour en fournir plusieurs versions, mais ça demande un effort non négligeable. Et on a déjà pas mal de boulot pour supporter correctement les dernières versions stables, LTS et autre rolling releases des distributions les plus courantes, donc peu de chances qu’on supporte les anciennes stables / LTS à courte terme.


#11

Je précise que nous n’avons pas les ressources pour garantir le bon fonctionnement du client sur toutes les saveurs de GNU/Linux et dans tous les environnements (Gnome, KDE, i3, Fluxbox…) mais que nous serions ravi·e·s de vous aider à vous prendre en main pour améliorer le fonctionnement de Cozy Drive sur votre distro / environnement de bureau favorit·e·s. Avis aux volontaires : Cozy a besoin de vous !


#12

Bonjour,

J’ai le même problème sur Mint 17.3 Cinnamon 64-bit

Error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version ‘GLIBCXX_3.4.21’ not found (required by / tmp/.org.chromium.Chromium.pbgx4T): unable to import leveldown

J’en profite pour signaler un petit oubli dans la traduction de la page
https://docs.cozy.io/fr/sync/linux/
"Then go to the Permissions tab and check the box to make the application executable: "


L’application GNU/Linux est gourmande en ressources
#13

Hello @alacool,

Manifestement, la version de GLIBCXX sur Mint 17.3 est trop vieille.

Est-ce que tu peux nous indiquer la sortie de strings $(locate -b '\libstdc++.so.6') | grep '^GLIBCXX_[0-9.]*$' | sort -V | tail -n 1 ? Si c’est une version plus ancienne que la 3.4.21 l‘application Cozy ne fonctionnera malheureusement pas :-S


#14

3.4.19
won won wonnn…

Je vais passer à la 18.3 dans ce cas là. :fist:


#15

Merci pour ta contribution : https://github.com/cozy-labs/cozy-desktop/commit/5d19dc5ff5e7ea2dbc3bc6181f09682f245c7079 :slight_smile:


#16

Linux Mint 18.3 Cinnamon 64-bit + Cozy Drive 3.4.5 = :heart_eyes_cat: