GPG key renew | renouvellement clef GPG


#1

Hello everyone,

As you may have noticed, the GPG key signing the Debian/Ubuntu Cozy repositories has expired.
This will prevent you from installing or updating your Cozy.

We have just extended the life of this key, available here.
If you are self-hosted, you must manually update it.
The procedure is as follows:

 apt-key del BCB2ED5D2765B235
 wget https://debian.cozycloud.cc/cozy.gpg.key -O /etc/apt/trusted.gpg.d/cozy.gpg
 apt update

You shouldn’t see errors appearing during the last command.


Bonjour à tous,

Comme vous avez pu le remarquer, la clef GPG signant les dépôts Debian/Ubuntu Cozy a expiré.
Cela vous empêche dorénavant d’installer ou de mettre à jour vos Cozy.

Nous venons d’allonger la durée de vie de cette clef, disponible ici.
Si vous êtes auto-hébergé, vous devez intervenir manuellement pour la mettre à jour.
La procédure est la suivante :

apt-key del BCB2ED5D2765B235
wget https://debian.cozycloud.cc/cozy.gpg.key -O /etc/apt/trusted.gpg.d/cozy.gpg
apt update

Vous ne devriez pas voir d’erreurs apparaître lors de la dernière commande.


[Debian packaging] KEYEXPIRED 1479315566
[fr][infolettre] Est-ce que la vie privée appartient au passé?
[en][newsletter] Is privacy a thing from the past?
#2

#3

#4

#5

Bonjour,

fait la procédure demandé ci-dessus mais j’ai toujours les messages d’erreur suivants :

Hit http://security.debian.org jessie/updates InRelease
Ign http://ftp.debian.org jessie InRelease       
Hit http://ftp.debian.org jessie Release.gpg     
Hit http://security.debian.org jessie/updates/main amd64 Packages
Hit http://ftp.debian.org jessie Release
Hit http://security.debian.org jessie/updates/main Translation-en
Hit https://debian.cozycloud.cc jessie InRelease              
Get:1 https://debian.cozycloud.cc jessie/main amd64 Packages [162 B]  
Get:2 https://debian.cozycloud.cc jessie/main Translation-en_US [162 B]
Get:3 https://debian.cozycloud.cc jessie/main Translation-en [162 B]
Get:4 https://debian.cozycloud.cc jessie/main amd64 Packages [162 B]
Err https://debian.cozycloud.cc jessie/main amd64 Packages
  HttpError404
Hit http://ftp.debian.org jessie/main amd64 Packages
Get:5 https://debian.cozycloud.cc jessie/main Translation-en_US [162 B]
Get:6 https://debian.cozycloud.cc jessie/main Translation-en [162 B]
Hit http://ftp.debian.org jessie/main Translation-en
Get:7 https://debian.cozycloud.cc jessie/main Translation-en_US [162 B]
Get:8 https://debian.cozycloud.cc jessie/main Translation-en [162 B]
Get:9 https://debian.cozycloud.cc jessie/main Translation-en_US [162 B]
Get:10 https://debian.cozycloud.cc jessie/main Translation-en [162 B]
Get:11 https://debian.cozycloud.cc jessie/main Translation-en_US [162 B]
Ign https://debian.cozycloud.cc jessie/main Translation-en_US
Get:12 https://debian.cozycloud.cc jessie/main Translation-en [162 B]
Ign https://debian.cozycloud.cc jessie/main Translation-en
W: Failed to fetch https://debian.cozycloud.cc/debian/dists/jessie/main/binary-amd64/Packages  HttpError404

E: Some index files failed to download. They have been ignored, or old ones used instead.

Y a-t-il autre chose à mettre à jour ?

Merci !


#6

Tu as un dépôt en trop dans ton fichier source.list.
Édite ton fichier /etc/apt/sources.list.d/cozy.list et remplace vire le main.


#7

J’ai remplacé main par cozy et ça a marché, merci !


#8

Same problem one year later : The following signatures were invalid: KEYEXPIRED 1510910396

/etc/apt/trusted.gpg.d/cozy.gpg

pub 2048R/2765B235 2014-11-17 [expired: 2017-11-17]
uid Cozy Debian Packaging debian-packaging@cozycloud.cc


#9

Merci @encolpe,

C’est exaspérant ce temps qui n’arrête pas de passer.

@aeris, qui peut mettre à jour la clé ?


#10

J’ai remonté à qui de droit :smiley:


#11

La clé m’est également indiquée comme invalide/expirée. Mais puisque Cozy est passé en V3 pour de bon, y-a-t-il une utilité à la mettre à jour ? Est-ce que Cozy V2 va continuer à recevoir des MàJ ?


#12

Non, Cozy V2 est mort, du moins pour CozyCloud :’( Nous ne procéderons plus à aucune mise à jour ni ne fournirons plus de support pour cette version.