Installationsfehler


#1

Bei der Installation unter Debian und Ubuntu giibt es einen Fehler, der dazu führt, dass das Gdebi-Paket-Installationsprogramm des BS nicht mehr startet. Die Fehlermeldung des Paket-Installers ist nicht sehr zielführend dabei.
Ermittelt habe ich folgendes:
Die Cozy Installation erstellt eine Datei mit Namen nodesource.list unter /etc/apt/sources.list.d/
Die Datei nodesources.list (Eigentümer root, Gruppe root) , hat keine Leserechte gesetzt für den Rest der Welt.
Das führt dazu, dass das Gdebi-Paket_installationsprogramm nach Installation von Cozy nicht oder nur mit Fehler startet und dann hängt. Dann können keine .deb Pakete mehr installiert werden.
Eine Änderung der Leserechte für diese Datei löst das Problem.Ich glaube das Installationsscript muss diesbezüglich geändert werden.
HW ZBox83, BS Debian 8.5 und/oder Ubuntu14.04
Hat jemand noch dieses Problem?
MFG
tdipeter


#2

Ich habe auch so ein Problem.
Hatte es unter virtualbox auf ubuntu server 16.04 versucht.

Werde es demnächst noch mal versuchen…

Gruß
Frank Drebin


#3

Terminalbefehl: sudo chmod o+r /etc/apt/sources.list.d/nodesource.list
Versuch das mal.
MFG
P. Tlusteck


#4

jepp so hats funktioniert, die Installation geht nun weiter.
Hast du das Problem schon gemeldet ?

Gruß
Frank