Modules manquants lors d'un yarn build

Bonjour,

Je suis en train de finaliser un connecteur pour la régie locale d’eau (Ileo) : cela fonctionne chez moi et je suis donc passé à la partie packaging. Là il y a un hic, lorsque je fais un yarn build :

WARNING in ./node_modules/cozy-konnector-libs/dist/libs/html2pdf.js 32:10-26
Module not found: Error: Can't resolve 'pdfjs' in '/home/mikael/utils/cozy-konnector-ileo/node_modules/cozy-konnector-libs/dist/libs'
 @ ./node_modules/cozy-konnector-libs/dist/index.js 21:13-49 22:25-73
 @ ./src/index.js 6:4-34

WARNING in ./node_modules/cozy-konnector-libs/dist/libs/html2pdf.js 33:20-56
Module not found: Error: Can't resolve 'pdfjs/font/Helvetica-Bold' in '/home/mikael/utils/cozy-konnector-ileo/node_modules/cozy-konnector-libs/dist/libs'
 @ ./node_modules/cozy-konnector-libs/dist/index.js 21:13-49 22:25-73
 @ ./src/index.js 6:4-34

WARNING in ./node_modules/cozy-konnector-libs/dist/libs/html2pdf.js 34:18-57
Module not found: Error: Can't resolve 'pdfjs/font/Helvetica-Oblique' in '/home/mikael/utils/cozy-konnector-ileo/node_modules/cozy-konnector-libs/dist/libs'
 @ ./node_modules/cozy-konnector-libs/dist/index.js 21:13-49 22:25-73
 @ ./src/index.js 6:4-34

WARNING in ./node_modules/cozy-konnector-libs/dist/libs/utils.js 252:12-47
Module not found: Error: Can't resolve 'pdfjs-dist/es5/build/pdf' in '/home/mikael/utils/cozy-konnector-ileo/node_modules/cozy-konnector-libs/dist/libs'
 @ ./node_modules/cozy-konnector-libs/dist/index.js 35:9-32
 @ ./src/index.js 6:4-34

J’ai essayé avec d’autres connecteurs (par exemple Ameli) et je rencontre le même souci. J’ai donc bien conscience que le problème se situe entre ma chaise et mon clavier. Mais je ne connais rien à yarn. Il me semble avoir bien suivi la doc sur la création de connecteurs. Notamment j’ai bien fait un yarn install et yarn standalone. Aurais-je loupé quelque chose d’important/évident ?

Merci !

Bonjour @mikael ,

Je crois que ces petites bêtes sont assez sensibles aux différences de versions. Est-ce que tu peux nous préciser les versions de Node et Yarn sur ton poste ?

Merci pour la réponse !

Yarn : 1.22.15
Node : 12.22.7

Pour être plus complet, voilà la sortie de yarn install

yarn install v1.22.15
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
warning " > cozy-konnector-libs@4.42.2" has unmet peer dependency "pdfjs@^2.3.0".
warning " > cozy-konnector-libs@4.42.2" has unmet peer dependency "pdfjs-dist@^2.1.266".
warning " > cozy-konnector-libs@4.42.2" has unmet peer dependency "zombie@^6.1.4".
warning "cozy-konnector-libs > cozy-client@23.22.0" has unmet peer dependency "cozy-ui@>34.0.0".
warning "cozy-konnector-libs > cozy-client@23.22.0" has unmet peer dependency "react@^16.7.0".
warning "cozy-konnector-libs > cozy-client@23.22.0" has unmet peer dependency "react-native@^0.64.1".
warning "cozy-konnector-libs > cozy-client@23.22.0" has unmet peer dependency "react-native-inappbrowser-reborn@^3.5.1".
warning "cozy-konnector-libs > cozy-client-js@0.19.0" has unmet peer dependency "babel-polyfill@^6.26.0".
warning "cozy-konnector-libs > cozy-doctypes@1.82.2" has unmet peer dependency "@babel/runtime@>=7.12.5".
warning "cozy-konnector-libs > cozy-doctypes@1.82.2" has unmet peer dependency "cozy-stack-client@>=13.15.1".
warning "cozy-konnector-libs > cozy-client > cozy-flags@2.7.1" has unmet peer dependency "react@^16.12.0".
warning "cozy-konnector-libs > cozy-client > react-redux@7.2.4" has unmet peer dependency "react@^16.8.3 || ^17".
warning "cozy-jobs-cli > cozy-client@23.4.0" has unmet peer dependency "cozy-ui@>34.0.0".
warning "cozy-jobs-cli > cozy-client@23.4.0" has unmet peer dependency "react@^16.7.0".
[4/4] Building fresh packages...
Done in 4.93s.

Puis de yarn build :

yarn run v1.22.15
$ webpack
asset index.js 6.16 MiB [emitted] (name: main)
asset LICENSE 33.7 KiB [emitted] [from: LICENSE] [copied]
asset icon.png 7.09 KiB [emitted] [from: assets/icon.png] [copied]
asset README.md 2.43 KiB [emitted] [from: README.md] [copied]
asset manifest.konnector 2.39 KiB [emitted] [from: manifest.konnector] [copied]
asset .travis.yml 1.59 KiB [emitted] [from: .travis.yml] [copied]
asset package.json 1.17 KiB [emitted] [from: package.json] [copied]
runtime modules 1.04 KiB 5 modules
javascript modules 5.35 MiB
  cacheable modules 5.35 MiB 881 modules
  25 modules
json modules 397 KiB
  modules by path ./node_modules/har-schema/lib/ 6.93 KiB 18 modules
  modules by path ./node_modules/iconv-lite/ 86.7 KiB 8 modules
  modules by path ./node_modules/entities/lib/ 30 KiB 4 modules
  modules by path ./node_modules/ajv/lib/ 5.58 KiB
    ./node_modules/ajv/lib/refs/json-schema-draft-06.json 2.46 KiB [built] [code generated]
    ./node_modules/ajv/lib/refs/json-schema-draft-07.json 2.72 KiB [built] [code generated]
    ./node_modules/ajv/lib/refs/data.json 409 bytes [built] [code generated]
  5 modules

WARNING in ./node_modules/cozy-konnector-libs/dist/libs/html2pdf.js 32:10-26
Module not found: Error: Can't resolve 'pdfjs' in '/tmp/cozy-konnector-ileo/node_modules/cozy-konnector-libs/dist/libs'
 @ ./node_modules/cozy-konnector-libs/dist/index.js 21:13-49 22:25-73
 @ ./src/index.js 6:4-34

WARNING in ./node_modules/cozy-konnector-libs/dist/libs/html2pdf.js 33:20-56
Module not found: Error: Can't resolve 'pdfjs/font/Helvetica-Bold' in '/tmp/cozy-konnector-ileo/node_modules/cozy-konnector-libs/dist/libs'
 @ ./node_modules/cozy-konnector-libs/dist/index.js 21:13-49 22:25-73
 @ ./src/index.js 6:4-34

WARNING in ./node_modules/cozy-konnector-libs/dist/libs/html2pdf.js 34:18-57
Module not found: Error: Can't resolve 'pdfjs/font/Helvetica-Oblique' in '/tmp/cozy-konnector-ileo/node_modules/cozy-konnector-libs/dist/libs'
 @ ./node_modules/cozy-konnector-libs/dist/index.js 21:13-49 22:25-73
 @ ./src/index.js 6:4-34

WARNING in ./node_modules/cozy-konnector-libs/dist/libs/utils.js 252:12-47
Module not found: Error: Can't resolve 'pdfjs-dist/es5/build/pdf' in '/tmp/cozy-konnector-ileo/node_modules/cozy-konnector-libs/dist/libs'
 @ ./node_modules/cozy-konnector-libs/dist/index.js 35:9-32
 @ ./src/index.js 6:4-34

4 warnings have detailed information that is not shown.
Use 'stats.errorDetails: true' resp. '--stats-error-details' to show it.

webpack 5.38.1 compiled with 4 warnings in 2946 ms
Done in 3.89s.

Merci !

Node 12 est je crois la version que nous utilisons.
Je n’ai plus touché à tout ça depuis fort longtemps donc je vais demander leur avis à mes camarades.

Est-ce que indépendamment de ces erreurs, tu arrives à compiler et lancer ton connecteur ?
Apparemment ce sont des avertissements liés à une évolution récente de dépendances, mais ça ne serait pas bloquant.

Ah oui en effet. Comme je voyais des Error: Can't resolve je pensais que c’étaient des erreurs bloquantes, mais non :upside_down_face:

Donc oui ça fonctionne bien, merci !

Je fais un nouveau sujet pour la publication du connecteur ?

Sensass !

Oui, je veux bien un sujet spécifique, merci !