Pas de renew de LET'S ENCRYPT


#1

Bonjour :slight_smile:
Alors j’ai toujours le même problème … Cela fait maintenant 3 mois que j’ai remis en place mon cozy (nouvelle installation tout propre) et je me retrouve aujourd’hui bloquer car mon certificat LE est périmé.
Pourtant mon port 80 est ouvert sur l’exterieur, le script (cozy-coclyco renew) dans /etc/cron.monthly ne doit pas se lancer et quand je lance la commande directement ben … rien ça tourne en rond :confused:

Merci de votre aide …


#2

Bonjour,

Idem ici : le certificat LE a expiré au bout de 3 mois malgré le script actif dans le cron mensuel. En lançant la commande manuellement, les opérations ont déroulé, mais je n’ai pas encore accès à mon Cozy.

# cozy-coclyco renew
[INF] cozy.isaring.fr expire in -1 day, 18:27:15.528168, renew
[INF] Issue certificate for {'cozy.isaring.fr', 'onboarding.cozy.isaring.fr', 'settings.cozy.isaring.fr', 'photos.cozy.isaring.fr', 'collect.cozy.isaring.fr', 'drive.cozy.isaring.fr', 'store.cozy.isaring.fr'}
[INF] Validate cozy.isaring.fr
[INF] Validate onboarding.cozy.isaring.fr
[INF] Validate settings.cozy.isaring.fr
[INF] Validate photos.cozy.isaring.fr
[INF] Validate collect.cozy.isaring.fr
[INF] Validate drive.cozy.isaring.fr
[INF] Validate store.cozy.isaring.fr
[INF] Request issuance for {'cozy.isaring.fr', 'onboarding.cozy.isaring.fr', 'settings.cozy.isaring.fr', 'photos.cozy.isaring.fr', 'collect.cozy.isaring.fr', 'drive.cozy.isaring.fr', 'store.cozy.isaring.fr'}
[INF] Fetch certificate for {'cozy.isaring.fr', 'onboarding.cozy.isaring.fr', 'settings.cozy.isaring.fr', 'photos.cozy.isaring.fr', 'collect.cozy.isaring.fr', 'drive.cozy.isaring.fr', 'store.cozy.isaring.fr'}

#3

Oups, désolé, on e na discuté en interne et je pensais avoir répondu.

En fait, le souci vient toujours de le nécessité d’utiliser la phrase de passe d’administration. Ça empêche de renouveler automatiquement les certificats, et manuellement le renouvellement ne fonctionnera que si vous avez exporté cette phrase de passe.

@aeris réfléchit à une solution mais ça n’est pas simple, à moins d’accepter de diminuer la sécurité globale.


#4

@isaring: As tu essayer de faire un /etc/init.d/nginx restart. Pour moi ça a fonctionner.


#5

Effectivement, redémarrer le service nginx a résolu le problème… tout simplement. :wink:


#6

Cool… Content que ça ai pu t’aider :+1: