Plantage du script /usr/share/cozy/konnector-create-chroot.sh


#1

Bonjour,

suite à la correction de cozy-stack j’ai relancé mon install cozy. Tout se passe bien sauf que lorsque je lance la commande /usr/share/cozy/konnector-create-chroot.sh j’ai ce message d’erreur :

CHROOT_DIRECTORY=/usr/share/cozy/chroot

  • DEBIAN_INCLUDE_PACKAGES=gnupg,apt-transport-https,ca-certificates,curl
    ++ lsb_release -sc
  • RELEASE=stretch
  • mkdir -p /usr/share/cozy/chroot
  • debootstrap --variant=minbase --include=gnupg,apt-transport-https,ca-certificates,curl stretch /usr/share/cozy/chroot
    I: Retrieving InRelease
    I: Retrieving Release
    I: Checking Release signature
    E: Invalid Release signature (key id 8B48AD6246925553)

Est ce que quelqu’un à la solution pour que je puisse passer cette étape ?

D’avance merci


#2
$ gpg --search-keys 8B48AD6246925553
gpg: data source: https://51.38.91.189:443
(1)     Debian Archive Automatic Signing Key (7.0/wheezy) <ftpmaster@debian.or
          4096 bit RSA key 0x8B48AD6246925553, créé : 2012-04-27, expire : 2020-04-25

A priori c’est lié à une clef du dépôt Debian.
Une signature qui aurait été mal faite chez eux ?


#3

En faisant un test chez moi :

+ CHROOT_DIRECTORY=/usr/share/cozy/chroot
+ DEBIAN_INCLUDE_PACKAGES=gnupg,apt-transport-https,ca-certificates,curl
++ lsb_release -sc
+ RELEASE=stretch
+ mkdir -p /usr/share/cozy/chroot
+ debootstrap --variant=minbase --include=gnupg,apt-transport-https,ca-certificates,curl stretch /usr/share/cozy/chroot
I: Retrieving InRelease 
I: Retrieving Release 
I: Checking Release signature
I: Valid Release signature (key id 067E3C456BAE240ACEE88F6FEF0F382A1A7B6500)

Je remarque que je n’ai pas du tout la même clef, qui est bien celle de Stretch et non de Wheezy.

$ gpg --search-keys 067E3C456BAE240ACEE88F6FEF0F382A1A7B6500
gpg: data source: https://37.191.231.105:443
(1)     Debian Stable Release Key (9/stretch) <debian-release@lists.debian.org
          4096 bit RSA key 0xEF0F382A1A7B6500, créé : 2017-05-20, expire : 2025-05-18

Es-tu bien sur une Debian Stretch ? :thinking:


#4

Hello @aeris,

je n’ai pas eu le temps de regarder, mais il me semble que oui. Je vérifie et reviens vers toi.


#5

Hello @aeris

Après vérification je suis bien sur une Stretch:

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 9.7 (stretch)
Release: 9.7
Codename: stretch

Du coup je vais chercher pour savoir comment corriger le problème mais si quelqu’un a une solution elle sera la bienvenue :slight_smile: