Sauvegarde des photos depuis Cozy Drive ne fonctionne plus


#61

Est-ce que vous pouvez confirmer que vous avez configurés Nginx pour faire du HTTP/2.0 ? (a priori, il suffit d’ajouter http2 à la directive listen )

Yes c’est bien le cas chez moi. Je vais essayer ce soir de changer la conf en http/1.0/1.1

J’arrive bien à synchroniser des photos sur une instance Cozy.cloud


#62

Salut @cpique, merci pour la confirmation.

Il semblerait que ce soit un bug Nginx lors de l’utilisation de HTTP/2 et du header Expect: 100-continue.
En tout cas, j’ai pu reproduire votre soucis (timeout dans les logcat, RST_STREAM dans les log Nginx et pas de photos dans Cozy) en ajoutant simplement http2 à la directive listen dans la conf Nginx. Du coup, je vous invite à le virer et à refaire vos tests.
Je suis pas allé plus loin que ça…

Par contre, je suis curieux de connaitre la conf Nginx utilisée pour les instances cozy.cloud. De ce que j’ai vu, c’est en HTTP/2 et l’upload des photos fonctionne.


#63

Nous n’utilisons pas Nginx mais Haproxy d’où effectivement de possibles différences de comportement entre notre infra et les instances auto-hébergées.


#64

Merci énormément !

Chez moi la suppression du paramètre http2 a résolu le soucis !

@Aeris : j’imagine que ce paramètre n’avait pas été mis là par hasard dans la conf par défaut.
J’avoue ne pas maitriser l’impact de la suppression du paramètre http2 de la directive listen


#65

Idem, en virant http2, ça remarche tout bien :slight_smile:
merci !


#66

Je me sens bête, mais comment vous faites pour désactiver HTTP/2.0 ?

J’ai supprimé le paramètre http2 de la directive listen de ma config nginx, redémarré nginx et la stack Cozy, mais mon app et mon navigateur se connectent toujours en HTTP/2.0…

Il y a autre chose à modifier et que j’ai raté ?


#67

Tu es sûr de taper sur le bon vhost / port ?
Il y a peut-être un autre intermédiaire entre ton smartphone et nginx ?


#68

Moi j’ai simplement dégég le http2 dans /etc/nginx/sites-available/mondomaine.fr
Restart de cozy-stack et de nginx. J’ai ensuite vérifié que le paramètre n’était plus dans la conf dans /etc/ningx/sites enabled


#69

tout pareil que @cpique !


#70

Bon, je dois avoir un truc bizarre dans ma config nginx, je vais creuser. Merci pour vos réponses !


#71

J’ai trouvé ! En fait il faut que http2 soit désactivé sur tous les hôtes nginx pour que HTTP/2.0 soit effectivement désactivé.

Par contre la question de l’utilisation ou non de HTTP/2.0 reste pertinente : c’est grave si on le désactive ? @aeris peut-être ?

Je me dis qu’il y a peut-être une option magique de nginx à activer, quelque part dans le module HTTP2 ?


#72

Non, ce n’est pas grave. L’utilisation d’HTTP/2.0 n’est qu’une optimisation pour charger plus rapidement les pages. Ça fonctionne très bien sans et ça ne pose pas de problème de sécurité. D’ailleurs, ça ne fait pas si longtemps que ça que l’on a du HTTP/2.0 chez nous (moins de 6 mois).


#73

Ok, merci @nono, je vais donc laisser ça comme ça en attendant que ça fonctionne correctement en HTTP/2.0.

Et un énorme merci à @lme d’avoir débloqué tout ça !