Self-Hosted : les konnectors ne fonctionnent pas

Hello @cpique,

Désolé, je n’ai pas de réponse précise à ton problème. Mais je me demandais… quitte à utiliser un certificat auto-signé, est-ce que tu ne pourrais pas faire un certificat générique, qui serait valide pour tous tes sous-domaines ? Un *.chezmoi.fr ?

Oups, je voulais dire que j’utilisais les certifs de letsencrypt …

Voici ce que j’ai pu trouver : il s’agirait d’un souci de chaining de mes certifs

SSL certificate chains

Some browsers may complain about a certificate signed by a well-known certificate authority, while other browsers may accept the certificate without issues. This occurs because the issuing authority has signed the server certificate using an intermediate certificate that is not present in the certificate base of well-known trusted certificate authorities which is distributed with a particular browser. In this case the authority provides a bundle of chained certificates which should be concatenated to the signed server certificate. The server certificate must appear before the chained certificates in the combined file


Est ce que ca parle à qqun ?

J’avais eu ce souci voilà fort longtemps, de mémoire c’est parce que dans le fichier de configuration de mon serveur web, je n’utilisais pas le bon fichier. Il fallait utiliser le fichier fullchain.pem. Mais je n’ai pas replongé le nez là dedans depuis longtemps, YunoHost gère cela tout seul, donc je ne sais pas si c’est encore d’actualité.

Je pense que je suis passé enter deux commit qui ont foiré ma config :
Je vois ca comme derniere maj sur le repo github de cozy-coclyco : “Store full chain and not only the first cert” par @aeris
j’ai solutionné ce WE en faisant à la main la concaténation mais ce n’est aps forcément super propre (car j’ai aussi retouché à la mimine ma config nginx -> au prochain renew ça va replanter)

Bonsoir,
j’ai installé Cozy sur une machine virtuelle sur mon synology, l’application est fonctionnelle mis à part les connecteurs.
J’ai regardé le tuto qui a été rédigé mais j’ai l’impression que des choses ont changés avec la version actuelle.
que doit on paramétrer en plus pour que les connecteurs fonctionnent?

Merci par avance

Bonjour @chulak,

Malheureusement, je ne sais pas si quelqu’un va pouvoir te répondre. Tu n’es pas le premier à essayer d’installer Cozy sur un NAS Synology, mais c’est une configuration que nous ne prenons pas officiellement en charge.

Une difficulté souvent rencontrée avec les connecteurs en auto-hébergement est qu’ils s’exécutent dans une machine virtuelle, via nsjail. Faire tourner nsjail dans une machine virtuelle n’est pas gagné.
L’emplacement du script qui lance les connecteurs est défini dans le fichier de configuration cozy.yml. Par défaut, c’est un script /usr/share/cozy/konnector-nsjail-run.sh. Tu peux probablement créer un autre script qui n’utilise pas nsjail, en t’inspirant par exemple de celui-ci.