Transfert fichier > 1Go et Quota


#1

Bonjour,

J’ai installé récemment les packages Cozy en auto-hébergement sous Debian Stretch. Je rencontre deux problèmes pour le moment, il m’est impossible de téléverser un fichier de plus d’un gigaoctet (.iso, .avi, .mkv, mp4). Il y a également un quota limité à 100 Go, qui n’est pas représentatif de l’espace disponible sur mon système de fichiers.

Merci d’avance pour votre aide


#2

Hello @Ryuk3n,

Bienvenue à bord :smile:,

Je me demande si le souci ne viendrait pas du Nginx qui sert de proxy devant Cozy. Est-ce que vous pourriez essayer d’ajouter dans la configuration de Nginx un client_max_body_size 0 (cf http://nginx.org/en/docs/http/ngx_http_core_module.html#client_max_body_size )

Concernant le quota de chaque instance, vous pouvez soit le définir lorsque vous créez l’instance au moyen de l’option --disk-quota (cf https://github.com/cozy/cozy-stack/blob/master/docs/cli/cozy-stack_instances_add.md ), soit utiliser la commande cozy-stack instances set-disk-quota pour modifier le quota d’une instance existante (cf https://github.com/cozy/cozy-stack/blob/master/docs/cli/cozy-stack_instances_set-disk-quota.md )


#3

Je ne m’attendais pas à une réponse aussi rapide et qui plus est avec de la documentation, c’est parfait !

J’ai fait les modifications et tout est bon pour moi. Il ne me reste plus qu’à “faire” fonctionner Cozy derrière un autre Nginx, les joies de l’auto-hébergement.

Merci encore @Clochix