[TUTORIEL] Mise en place COZY V3 en auto-hébergé


#21

Je profite que tu sois en train de réécrire le tuto pour pointer une coquille

echo "export COZY_ADMIN_PASSWORD=<votre-mot-de-passe-administrateur>" > \
~/.bashrc

Je ne pense pas que tu veuilles effacer le bashrc de tes lecteurs : s/>/>>/ :wink:


#22

oui en effet merci @Fol


#23

Merci @Clochix. Je pense que ce n’est pas grand chose mais je préfère bien faire les choses :slight_smile:


#24

Hum, à vu de pif, je dirais que tu n’as pas configuré les backports, et donc qu’apt ne trouve pas la bonne version de python3-acme.


#25

Dans le fichier /etc/apt/preferences.d/cozy, j’ai ça :

Package: python3-acme
Pin: release n=stretch-backports
Pin-Priority: 510

Je n’ai pas mis le EOF c’est peut etre ça ?

/////////////////////////////////////
You may change your APT preferences to allow APT to install from backports/ppa by default instead of from official repositories. For example:

/etc/apt/preferences.d/cozy 
Package: python3-acme
Pin: release n=stretch-backports
Pin-Priority: 510
EOF

#26

Non, il n’y a pas d’EOF, c’est juste un signal pour que cat <<EOF s’arrête, il n’arrive pas dans le fichier final.
Est-ce que tu pourrais me donner la sortie de apt policy et de apt policy python3-acme ?


#27


#28

A priori tu n’as pas activé backport dans ton source.list donc


#29

je pensais que l’ajout du fichier cozy dans preference.d suffisait ! non ?
Il faut aussi que j’ajoute backports dans mon sources.list c’est ça


#30

Hello tout le monde !!

Gros problème ce matin, je souhaite me connecter à mon cozy et là impossible certificat expiré. Je pensais que cozy renouvellait automatiquement les certificats mais bon … je lance la commande “cozy-coclyco renew” et la rien pas de message d’erreur le terminal semble travailler mais au bout de 10 minutes toujours pas d’information …

Avez vous un conseil pour moi ?

Merci d’avance

edit : j’ai regarde dans le dossier /etc/letsencrypt/renewal/ et j’ai bien un nom de domaine mais pas celui de cozy … je pense que l’erreur est là mais je ne sais pas comment la corrigé


#31

Salut, même problème pour moi à l’instant, certificat expiré…Par contre un cozy-coclyco renew a fonctionné.

Question idiote mais est-ce que tu as pensé au export COZY_ADMIN_PASSWORD=xxxx moi j’oublie de le faire à chaque fois ?


#32

@onome

Je viens de “resoudre” mon problème comme ceci. (Si quelqu’un @Clochix ou @aeris) pourrais confimer mes “dires” :

// A faire sous l'utilisateur root

// J'arrête le service nginx
- /etc/init.d/nginx stop

// Génération des certificats LE (penser à ouvrir votre port 80 vers votre cozy)
certbot certonly --standalone --agree-tos -m votreadresse@mail.fr -d cozy.mondomaine.fr -d onboarding.cozy.mondomaine.fr -d drive.cozy.mondomaine.fr -d photos.cozy.mondomaine.fr -d collect.cozy.mondomaine.fr -d settings.cozy.mondomaine.fr -d store.cozy.mondomaine.fr --rsa-key-size 4096 --preferred-challenges http

// Si ce n'est pas fait je créer un lien symbolique entre le certificat crée par LE et celui utilisé par mon fichier de configuration : /etc/nginx/sites-availables/mondomaine.fr.conf ( à adapter selon votre fichier)
- ln -s /etc/letsencrypt/live/mondomaine.fr/fullchain.pem /etc/ssl/private/mondomaine.fr.crt
( au besoin faire un " rm /etc/ssl/private/mondomaine.fr.crt" avant)

- ln -s /etc/letsencrypt/live/mondomaine.fr/privatekey.pem /etc/ssl/private/cozy.pem
( au besoin faire un " rm /etc/ssl/private/cozy.pem" avant)

// Redémarrer le service nginx
- /etc/init.d/nginx start

et normalement votre cozy sera opérationnel.

Des que j’ai un peu de temps et que j’ai finaliser mon tuto, je rajouterai cette partie avec ajout dans crontab.

J’espère que ça pourra t’aider sinon reviens vers moi


#33

Alors oui mais non, il ne faut pas utiliser certbot si tu utilises coclyco. Les 2 sont incompatibles entre eux.
Si ton certificat avait expiré avant, c’est que tu avais du oublier de mettre coclyco dans une crontab pour qu’il renouvelle les certificats comme un grand.


#34

il faut que je met “cozy-coclyco renew” dans un cron c’est bien ça

Le fait que j’ai utilisé la commande “certbot” va me poser problème maintenant ?


#35

Oui, c’est bien ça.
Pour certbot, il faut que tu regardes la doc pouvoir voir comment désactiver le renouvellement sur ce certificat.
Et du coup penser à supprimer les liens symboliques que tu as créés.


#36

Je viens de relancer cozy-coclyco renew avec le conseil de @onome
mais je reste bloquer sur " [INF] Creating new master key /etc/ssl/private/cozy.pem"

J’ai regardé au niveau de la documentation let’s encrypt mais je n’ai rien trouvé … je n’ai pas utilisé la commande pour les “renew” mais juste pour la génération du certificat donc je pense que je n’ai rien n’a annuler !

Par contre il y a une section sur la doc LE pour révoquer le certificat, tu penses que c’est ça ?


#37

Tu as un problème quelque part ailleurs alors.
Ce truc est supposé être instantané.

Oui justement, ça les met automatiquement en file pour le renouvellement avec certbot.


#38

D’ailleurs c’est étonnant que ça te relance une création de compte auprès de LE.
Tu ne t’en étais jamais servi auparavant ? :thinking:


#39

heu non pas de souvenir en tout cas … j’ai suivi le tuto à la lettre :slight_smile: et tu m’avais dit que cozy-coclyco générait les certificats LE automatiquement


#40

C’est bon ça marche voici ce que j’ai fais (si ça peut servir à quelqu’un un jour) :

// Suppression via LE du lien certificat / nom de domaine

// Regeneration des certificats
cozy-coclyco regenerate

// Au besoin pour les renouvellements.
cozy-coclyco renew

Merci à tous de votre aide

N.B. @aeris : est ce que j’ai besoin d’arreter le service nginx pour le renew avec la commande cozy-coclyco ou je peux directement faire :

$ sudo crontab -e

# Add this to the crontab and save it:
0 0 2 * * cozy-coclyco renew