[TUTORIEL] Mise en place COZY V3 en auto-hébergé


#61

As tu bien lien ton adresse ip extérieur aux différents noms de domaine ?


#62

Il me semble que ce que j’ai fait est correct, oui. Chez Gandi j’ai deux enregistrements :

  • un de type A de cozy vers mon IP externe
  • un de type CNAME de *.cozy vers cozy

:confused:


#63

Quand tu ping onbording.tondomaine.fr (et les autres) ça te retourne bien ton ip Wan?


#64

Affirmatif ! :slight_smile:

Un ping sur cozy.isaring.fr ou onboarding.cozy.isaring.fr retourne bien mon IP publique.

J’ai testé d’autres commandes, c’est vraiment ce port 443 qui semble verrouillé…

Par exemple :
# nmap localhost Starting Nmap 7.40 ( https://nmap.org ) at 2018-08-01 21:32 CEST Nmap scan report for localhost (127.0.0.1) Host is up (0.000089s latency). Other addresses for localhost (not scanned): ::1 Not shown: 995 closed ports PORT STATE SERVICE 22/tcp open ssh 25/tcp open smtp 80/tcp open http 8080/tcp open http-proxy 9001/tcp open tor-orport Nmap done: 1 IP address (1 host up) scanned in 4.04 seconds

Comme tu peux le voir, mon RPi fait aussi tourner un relais tor mais cela devrait être sans incidence sur le fonctionnement de Cozy…

Autre commande :
# netstat -anltp | grep ":80" tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 2379/nginx: master tcp 0 0 127.0.0.1:8080 0.0.0.0:* LISTEN 334/cozy-stack tcp6 0 0 :::80 :::* LISTEN 2379/nginx: master

Tandis que la même commande avec un grep “:443” me retourne bien les connexions où les clients de mon relais tor arrivent en sur leur port 443 mais rien de mon côté sur mon IP locale.

Par exemple :
tcp 0 0 192.168.0.42:43816 62.210.5.178:443 ESTABLISHED 1057/tor

Visiblement, je ne sais tout simplement pas faire en sorte que ce port soit ouvert pour la stack cozy ! :neutral_face:


#65

Si ton rpi utilise déjà le port 433 avec le service tor c’est normal qu’il ne puisse pas. L’utiliser avec cozy. Deux moyen modifier le port de cozy ou bien celui de tor par un autre.


#66

Non, tor utilise le port 9001 sur ma machine, ce sont les utilisateurs du réseau tor qui utilisent leur port 443 pour se connecter à mon relais.

Je note que dans le dossier /etc/nginx/sites-available/, je n’ai que le fichier default, pas de fichier lié à mon domaine (mais c’est peut-être cozy-coclyco qui le crée… non ?)


#67

Peux tu me mettre le contenu de ton fichier default stp !


#68

Le voilà :

# cat /etc/nginx/sites-available/default
##
# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# https://www.nginx.com/resources/wiki/start/
# https://www.nginx.com/resources/wiki/start/topics/tutorials/config_pitfalls/
# https://wiki.debian.org/Nginx/DirectoryStructure
#
# In most cases, administrators will remove this file from sites-enabled/ and
# leave it as reference inside of sites-available where it will continue to be
# updated by the nginx packaging team.
#
# This file will automatically load configuration files provided by other
# applications, such as Drupal or Wordpress. These applications will be made
# available underneath a path with that package name, such as /drupal8.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##

# Default server configuration
#
server {
        listen 80 default_server;
        listen [::]:80 default_server;

        # SSL configuration
        #
        # listen 443 ssl default_server;
        # listen [::]:443 ssl default_server;
        #
        # Note: You should disable gzip for SSL traffic.
        # See: https://bugs.debian.org/773332
        #
        # Read up on ssl_ciphers to ensure a secure configuration.
        # See: https://bugs.debian.org/765782
        #
        # Self signed certs generated by the ssl-cert package
        # Don't use them in a production server!
        #
        # include snippets/snakeoil.conf;

        root /var/www/html;

        # Add index.php to the list if you are using PHP
        index index.html index.htm index.nginx-debian.html;

        server_name _;

        location / {
                return 301 https://$host$request_uri;

                # First attempt to serve request as file, then
                # as directory, then fall back to displaying a 404.
                try_files $uri $uri/ =404;
        }

        location /.well-known/acme-challenge/ {
                alias /etc/ssl/private/acme-challenge/;
        }

        # pass PHP scripts to FastCGI server
        #
        #location ~ \.php$ {
        #       include snippets/fastcgi-php.conf;
        #
        #       # With php-fpm (or other unix sockets):
        #       fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
        #       # With php-cgi (or other tcp sockets):
        #       fastcgi_pass 127.0.0.1:9000;
        #}

        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        #location ~ /\.ht {
        #       deny all;
        #}
}


# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.
#
#server {
#       listen 80;
#       listen [::]:80;
#
#       server_name example.com;
#
#       root /var/www/example.com;
#       index index.html;
#
#       location / {
#               try_files $uri $uri/ =404;
#       }
#}

#69

Hello,

Y a moyen d’avoir une procédure d’installation à jour ? ou une image toute faite ? (je sais je rêve :wink:)


#70

Hello @doune,

Pour la documentation, nous essayons de tenir cette documentation à jour, même si je reconnais qu’il faut parfois plusieurs jours entre la publication d’une évolution du système et la mise à jour de la documentation.
Pour ce qui concerne une image toute faite, ça n’est pas à l’ordre du jour. Créer une telle image ne serait pas compliqué, mais la mettre à jour demanderait d’y passer régulièrement du temps, et pour l’heure nous sommes trop occupés par d’autres tâches pour pouvoir prendre ce temps :-S


#72

Je bosse sur l’actualisation du tuto que j’ai fait mais malheureusement je galère moi même avec certains soucis (restauration de ma backup sur un nouveau cozy) … Et je ne mentirai pas en disant que le projet cozy pour les auto hébergé n’est plus ce qu’il était à son origine… D’où mon manque de motivation je pense. Des que j’aurais enfin réussi à restaurer ma backup (je n’ai pas essayer depuis) je promet d’actualiser le tuto. En attendant tu peux t’appuyer dessus quand même car les idées principales y sont déjà présentes.
bon courage.


#73

Merci par avance @gudbes
J’avoue que c’est ce qui me freine un peu ajd pour passer sur du autohébergé : une documentation claire et complète de l’install et de la configuration.


#74

Tu as regardé ici pour débuter : https://forum.cozy.io/t/tutoriel-mise-en-place-cozy-v3-en-auto-heberge/


#75

Oui j’ai bien suivi cela.
Mais je suis en ubuntu 18.04 LTS et j’ai des soucis avec les paqutes.
cozy-couchdb : Dépend: libmozjs185-1.0 (>= 1.8.5-1.0.0+dfsg) mais il n’est pas installable
Idem, il y a des dépendances avec libcurl3 et curl qui dépend lui même de libcurl4 -> conflit
Il n’y apparemment pas de dépôt compatible avec ubuntu 18.04 (sauf s je dis une connerie). Je vais ptet tenter une réinstall en debian.


#76

Hello @cpique,

Tu ne dis pas de bêtises, pour l’instant nous ne proposons de paquets que pour Ubuntu 16.04, nous n’avons pas encore trouvé le temps de faire la mise à jour vers la 18.04 (et vu le planning chargé d’Æris, je ne sais pas quand il pourra s’en occuper).


#77

Ok merci :wink:

Du coup je suis reparti sur une debian 9.

Cependant j’ai un soucis lorsque je lance cocyclo.
J’ai un unique message qui apparait :

[INF] Create instance cozy.domaine.ovh with email xxx.xxx@gmail.com

Rien ne se passe ensuite, et je termine systématiquement avec un Ctrl C
Voici le message:

Traceback (most recent call last):
  File "/usr/bin/cozy-coclyco", line 11, in <module>
    load_entry_point('cozy-coclyco==1.0', 'console_scripts', 'cozy-coclyco')()
  File "/usr/lib/python3/dist-packages/cozy/coclyco/__init__.py", line 56, in cli
    args.cmd(args)
  File "/usr/lib/python3/dist-packages/cozy/coclyco/pki.py", line 114, in create_instance
    email)
  File "/usr/lib/python3/dist-packages/cozy/coclyco/cmd.py", line 65, in exec
    retcode = process.wait()
  File "/usr/lib/python3.5/subprocess.py", line 1389, in wait
    (pid, sts) = self._try_wait(0)
  File "/usr/lib/python3.5/subprocess.py", line 1339, in _try_wait
    (pid, sts) = os.waitpid(self.pid, wait_flags)
KeyboardInterrupt

Une idée de ce qui pourrait causer cela ?

Merci par avance !

Je précise que j’ai bien renseigné la variable COZY_ADMIN_PASSWORD (dans mon bashrc ainsi qu’en ligne de commande juste avant pour voir si cela changeait qque chose.


#78

@cpique: Essaye de détruire ton instance et de recommencer. T’es ports 80 et 443 sont ils bien ouvert ?


#79

Bienvenue au club @cpique :wink:

Voir mon post #58


#80

bizarre je viens de créer 2 instances sur une installation toute propre (debian stretch) et aucun soucis !


#81

Définir la variable ne suffit pas, il faut aussi penser à l’exporter !
Donc dans le bashrc ou sur la ligne de commande export COZY_ADMIN_PASSWORD=xxxx.
Sans le export, ça ne fonctionnera pas.