Unable to log into Cozy on RPi 2


#1

I had just flashed an image on the SD card of my RPi 2. After setting stuff up on the pi and in the browser, I tried to log in through the displayed login page. I know my password is correct, but when I click on the log in button, it turns into a green check mark and reloads the login page where it asks me to enter my password. This keeps happening again and again. Please help. :frowning:


#2

Have you tried to connect through HTTPS ? What you describes always occur when you try to connect in http.


#3

Hello @Jerome,

Welcome aboard :smile:

Do you try to log using http or https? Your server should only be available through httpS, if it detects you’re trying to access htrough http, it will redirect you to the login page. This looks like the behavior you’re experimenting.
Also have you set up a TLS certificate? It is self-signed, or do you use Let’s Encrypt?


#4

The login page does say https (https://192.168.1.94/login)

I have just flashed the img file for the RPi2 that I got from the cozy website. I have not setup any kind of certificate.

:smiley:


#5

Well, this behavior is pretty strange.
Do you block cookies or use some browser extension that block content to protect your privacy?