Welcome! Your Cozy has not been yet activated.


#1

I did manual installation with little help of (amazing btw) tool cozy-coclyco.

What is the activation message about? I can’t see anything in the logs and no email was delivered (I most likely have wrong SMTP configuration).

Can it be due to my configuration item?
registries:
- https://registry.cozy.io/

What to do to be able to access my instance?

Thank you in advance,
Tomas


changing mail servers
#2

Hi @katomaso,

At the end of the cozy-coclyco create command, you have an URL to activate your cozy.


#3

Oh that is unfortunately gone. cozy-cyclo create crashed when verifying certificates and I didn’t have the guts to run it again in case it is not idempotent.

How to get the token now?

From looking into the code I see I need to call https://<my-domain>/?registerToken=THE-TOKEN but which token is it? I tried cozy-stack instances show <my-domain> and then using value from register_token JSON item. But that didn’t work. Neither cozy-stack instances token-app <my-domain> <slug> did. Please help.


#4

Token you get from cozy-stack instances show is base64 encoded. You need to use the hex encoded version on the registration URL.
To convert it : echo -n "<base64 token>" | base64 -d | xxd -p

I will add a command on coclyco to be able to directly get the registration url of an already created instance :slight_smile:


#5

Thank you! it worked like a charm. It is a bit magical transformation thus it would deserve its own command.


#6